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Solid state equipment has operational characteristics differing from those of 
electromechanical equipment.  “Safety Guidelines for the Application, 
Installation and Maintenance of Solid State Controls” describes some important 
differences between solid state equipment and hard-wired electromechanical 
devices.  Because of this difference, and also because of the wide variety of uses 
for solid state equipment, all persons responsible for applying this equipment 
must satisfy themselves that each intended application of this equipment is 
acceptable. 

Important User 
Information 
 

 
In no event will the Helm Instrument Company be responsible or liable for 
indirect or consequential damages resulting from the use or application of this 
equipment. 

 
The examples and diagrams in this manual are included solely for illustrative 
purposes.  Because of the many variables and requirements associated with any 
particular installation, the Helm Instrument Company cannot assume 
responsibility or liability for actual use based on the examples and diagrams. 

 
No patent liability is assumed by Helm Instrument Company with respect to use 
of information, circuits, equipment, or software described in this manual. 

 
Reproduction of the contents of this manual, in whole or in part, without written 
permission of the Helm Instrument Company is prohibited. 

 
Throughout this manual we use note to make you aware of safety 
considerations. 
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ATTENTION: Identifies information about practices or 
circumstances that can lead to property damage. Identifies 
information that is especially important for successful 
application and understanding of the product. 

 
Attentions help you: 
• identify a hazard 
• avoid the hazard 
• recognize the consequences 
 

 
                                                                                                                                

ATTENTION: Please check power supply ratings before 
proceeding!  Each tonnage module consumes (+24, 173 mA  
+5, 220mA).  Be sure to not overload the power supply.            
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Preface 
 

Read this preface to familiarize yourself with the rest of this manual.  This 
preface covers the following topics: 
 
• who should use this manual 
• the purpose of this manual 
• terms and abbreviations 
• conventions used in this manual 

 
 
 

Who Should Use this Manual 
 

Use this manual if you are responsible for the design, installation, 
programming, or maintenance of an automation control system. 
 
You should have a basic understanding of a Profibus DP network.  You 
should understand electronic process control and be able to interpret the 
ladder logic instructions required to generate the electronic signals that 
control your application. 

 
 

Purpose of This Manual 
 

This manual is a learning and reference guide for the Helm HM-2-SSI 
Module.  It contains the information you need to install, wire, and use the 
module. 
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Contents of this Manual 

Chapter Title Content 

 Preface 

Describes the purpose, background, and 
scope of this manual.  Also specifies the 
audience for whom this manual is intended 
and defines key terms and abbreviations 
used throughout this book. 

1 Overview 
Provides a hardware and system overview.  
Explains and illustrates the components of 
the system. 

2 Installation and Wiring Provides installation information and wiring 
guidelines. 

3 Channel Configuration, 
Data and Status 

Examines the channel configuration and the 
channel status word, and explains how the 
module uses configuration data and 
generates status during operation. 

4 Initial Setup Procedures 
Gives setup instructions for initial setup.  
This includes the hardware setup, as well as 
installing the GSD file, and Siemen’s ladder 
logic. 

5 Troubleshooting 
Explains how to interpret and correct 
problems that occur while using the load 
module. 

A Specifications 
Provides physical, electrical, Environmental, 
and functional Specifications for the 
module. 

B Module Diagrams 

 
Included diagrams are the load module 
layout, Profibus wiring, strain gage wiring 
module I/O wiring, master/slave config. 
Wiring, and encoder wiring.  
 

C GSD File 

 
GSD files are used by Profibus 
configuration tools to enable a master 
Profibus scanner module - either in a PLC or 
PC - to know what slave devices are to be 
communicated to, their node address, what 
parameters can be read and written to and 
more. 
 

D Address Values Provides Image Blocks 

E Siemen’s Ladder Logic Provides Siemen’s Ladder Logic program 

Preface 
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 Terms and Abbreviations 
 
The following terms and abbreviations are used throughout this manual. 
 
Calibration - Procedure, performed by trained personnel, where machine or press is dynamically 
loaded to impact on load cells.  This is the process of linearity measuring to determine the 
loading capacity of the machine. 
 
Calibration Number - An amplification values established during machine calibration or pre-
assigned on force load cells. 
 
Channel - Refers to one of two, strain gage inputs available on the modules terminal block.   
 
Configuration Word - Contains the channel configuration information needed by the module to 
configure and operate each channel.  Information is written to the configuration word through the 
logic supplied in your ladder program. 
 
HM-2-SSI - Helm monitoring module; provides processor input from up to two sensors. 
 
Gain - Amplification of an input signal. 
 
Load/Force - Measurement of impact during a machine cycle.  Sensors provide the input for this 
measurement. 
 
Look Window - Resolver or cam activated window which allows specific degrees in a machine 
cycle to be processed. 
 
Low Alarm Inhibit - Number of consecutive machine cycles where low alarm is inhibited.  
Used in a process where machine cycles several times before running speed is established. 
 
LSB - (Least Significant Bit) Refers to a data increment defined as the full scale range divided 
by the resolution.  The LSB represents the smallest value within a string of bits. 
 
Monitor Parts Mode - Status condition used during production run.  Sample and compare logic 
is enabled.  On resolver based systems, tracking alarm limits can be enabled. 
 
Press Curve - Machine manufacturers provide this data table which defines limits on maximum 
load that should be exerted at a given degree of press stroke.  This data is stored in EEPROM 
memory in the Helm processing unit. 
 
Press Curve Alarm - Indication of resolver position and load when load at a given degree meets 
or exceeds press curve profile. 
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Resolution - The smallest detectable change in a measurement, typically expressed in 
engineering units (e.g. 0.15C) or as a number of bits.  For example a 12-bit system has 4,096 
possible output states.  It can therefore measure 1 part in 4096. 
 
Resolver - Sometimes called encoder.  Device attached on a machine to determine stroke 
position.  Sine/cosine based resolver required for Helm systems. 
  
Reverse Load - Measurement of negative load/force being exerted on machine following the 
break-through of material, also referred to as snap through.  
 
Sample - Load/force values established from a series of machine cycles, also defined as 
benchmark. 
 
Sample Count - User input value used to specify how many machine cycles to base the sample 
on. 
 
Sampling time - The time required by the A/D converter to sample an input channel. 
 
Scale - Value used to describe the press/machine overall tonnage.  Set for maximum value of one 
channel.  For example, settings for a 150 ton press = 75. 
 
Setup Mode - Status condition of monitor typically enables during die setup.  Machine capacity 
alarms are enabled.  On resolver based systems, press curve alarm can be enabled.  This mode is 
also used during machine and resolver calibrations. 
 
Status Word - Contains status information about the channel’s current configuration and 
operational state.  You can use this information in your ladder program to determine whether the 
channel data word is valid. 
 
Target Load - A reference load established by the user.  Used primarily during setup to improve 
setup time. 
 
Tolerance /Trend Alarm - User defined upper and lower control limits established during the 
sample and compare process.  These limits are established on the peak load and will activate the 
machine stop relay when exceeded. 
 
Tracking Alarm - Requires resolver input. The sample and compare process is applied to the 
entire forming force based on user selected upper and lower control limits. 
 
Trend Deviation - Percent of change, high and low, from sample value to current value. 
 
TSM - Acronym for Through-the-Stroke load monitoring. Resolver input is required for 
monitoring the load being developed during machine cycle. 
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Common Techniques Used in this Manual 
 

The following conventions are used throughout this manual: 
 

• Bulleted lists such as this one provide information, not procedural steps. 
• Numbered lists provide sequential steps or hierarchical information. 

 
 
 

Product Support 
 
Contact your Helm representative or call Helm direct at 419/893-4356: 
 

• sales and order support 
• product technical training 
• warranty support 
• support service agreements 

 
 
 

Your Questions or Comments on this Manual 
 
If you have any suggestions for how this manual could be made more useful to you, 
please send us your ideas. 
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 Chapter 1 
 

Overview 
 

You have just purchased the most advanced strain monitoring solution 
available.  HELM INSTRUMENT COMPANY, INC. manufactures a 
complete line of strain monitoring control solutions for use on metal 
stamping, forging, compaction and assembly presses; cold forming, cold 
heating, injection molding and die cast machines. 
 
At HELM, quality is inherent not only in the design of our products but in 
the attitudes of our employees as well.  We’re working together to give 
you the best.  After all, that’s what our business is all about - providing 
innovative instrumentation to help make your manufacturing process more 
productive and your operation more effective. 
 
The Helm HM-2-SSI combines machine and tooling monitoring with 
programmable limit switch function.  User programmable high and low 
limits protect the machine and tooling to ensure part quality. 
 

 

Strain Gain Transducer Operation 
 
The primary part of the load monitoring system centers around the 
measurement.  The basic function of the Helm Strain Gain sensor is to 
detect the amount of deflection imposed on the press or die  as parts are 
being formed.  All Strain Gain sensors are matched to within 1% and 
therefore can be replaced without recalibration of the machine. 
 
The Helm Strain Gain sensors can be mounted to strategic high stress 
areas of the machine frame or strategically located in tooling or applied to 
stop blocks.  Signals from these sensors are routed to the HM-2-SSI 
module for processing.  The Helm Strain Gage is capable of measuring 
either a tension or compression signal. 
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HM-2-SSI Features 
 
 

• Two channel Strain Gage input with Auto Zero (350-700 ohm) 
  
• PROFIBUS DP slave 

 
• DIN rail mount 

 
• Peak models 

 
• Pre-programmed screens for Siemens HMI's 

 
• Applications include Stamping, Forging, Die Cast, Injection Molding, 

Assembly and Weigh Scale 
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Hardware Overview 
 
 

The force module uses Profibus communications.  It interfaces to strain 
gage based transducers (350ohm or 700ohm). 
 
The HM-2-SSI module receives and stores digitally converted analog data 
into its image table for retrieval on a Profibus network.  The module 
supports connections from two strain gage sensors. 
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Hardware Features 
 
 

 
 
 

METER/MESSAGE DISPLAY: 
 

- The message display shows menu settings, and calibration values. 
 

BALANCE ADJ. (CH. 1): 
 

- Used to set CH. 1’s amplifier to 0. 
 

GAIN ADJ. (CH. 1): 
 

- Used to adjust CH.1’s calibration number or gain value. 
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RECORDER OUTPUT JACK: 
 

- The recorder output jack outputs the analog signals of CH. 1 and CH. 2. 
 

 
BALANCE ADJ. (CH. 2): 
 

- Used to set CH. 2’s amplifier to 0. 
 

GAIN ADJ. (CH. 2): 
 

- Used to adjust CH.2’s calibration number or gain value. 
 

PROFIBUS CABLE CONNECTION: 
 

- Profibus communication jack 
 

MODE STATUS LED’S: 
 

- Calibration LED 
 

o This LED is lit if the module’s calibration resistor is on. 
 

- AZ 
 

o This LED is lit when Auto-Zero (AZ) is turned on. 
 

- Status 
 

o Solid Green → Online Profibus Communications 
 
o Flashing Green → Offline Profibus Communications 

 
o Solid Red → ERROR: Profibus Communication Fault 

  
 
 
 
 
 
 

10 of 39 
© 2006 by Helm Instrument Co., Inc. All Rights Reserved 
12/6/2006 v1.00 



HM-2-SSI Module 
Instruction Manual CHAPTER 1 

 

UP/DOWN BUTTONS: 
 

- The up/down buttons are used to change settings and values. 
 

 

SELECT/ENTER BUTTON: 
 

- This button allows the user to navigate through the menu. 
 
 

MODE/STORE BUTTON: 
 

- This button turns Calibration Mode on and off. 
 
- When in other settings, this button is used to save the current values to the 

module’s EEPROM. 
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 Chapter 2 
 
 
 

Getting Started 
 

This chapter can help you to get started using the Helm HM-2-SSI module.  
The procedures included here assume that you have a basic understanding of 
Profibus communications.  You should understand electronic process control 
and be able to interpret the ladder logic instructions required to generate the 
electronic signals that control your application. 
 
Because it is a start-up guide, this chapter does not contain detailed 
explanations about the procedures listed.  It does, however, reference other 
chapters in this book where you can get more information about applying the 
procedures described in each step. 
  
If you have any questions or are unfamiliar with the terms used or concepts 
presented in the procedural steps, always read the referenced chapters and 
other recommended documentation before trying to apply the information. 

 
This chapter will: 

 
• tell you what equipment you need 
• explain how to install and wire the module 
• show you how to set channels for the sensor input 

 

Required Tools and Equipment 
 

Have the following tools and equipment ready: 
 

• small blade screwdriver 
• potentiometer trimmer (tweeker) 
• appropriate strain gage cable 
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System Operation 
 
The HM-2-SSI module communicates to a PLC through Profibus and 
receives+24Vdc power from an external power supply.  
 
Each individual channel on the module can receive input signals from strain 
gage based sensors.  The module converts the analog values directly into 
digital values. 

 
 

Sensor Wiring 
 

The module contains an 8-pin orange connector for wiring to the strain gages 
or load cells. The pin-out is shown below for both types used. 
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Channel Configuration Data and Status 
 

This chapter explains how the HM-2-SSI module communicates though the module’s 
input and output image using Profibus.  It lists the preliminary setup and operation 
required before the module can function. 

 

Output Image Block 

SSI-2 PLM    OUTPUT BLOCK (DB2) 
This data block is the image of the output of the module. You can control the behavior of 
the module from this area such as setting the tonnage alarm limit values, changing the 
module’s mode of operation, and etc.  

Block:
DBDB2 

Data 
Type Bit Description 

INT   
0 
1 
2 

Set Calibrate mode 
Set Setup mode 
Set Monitor Mode 

+0.0 
Bit 
Bit 
Bit 
Bit 
Bit 
Bit 

8 
9 
10 

 
Alarm Reset 
 

+2.0 INT - Spare 
+4.0 INT - Set Ch1 High Capacity Alarm Value (in Calibrate mode) 
+6.0 INT - Set Ch2 High Capacity Alarm Value (in Calibrate mode) 
+8.0 INT - Set Sample Count (2, 4, 8, or 16) 
+10.0 INT - Set Low Alarm Inhibit Count 
+12.0 INT - Set Ch1 Low Tolerance value 
+14.0 INT  Set Ch1 High Tolerance value 
+16.0 INT  Set Ch2 Low Tolerance value 
+18.0 INT - Set Ch2 High Tolerance value 

INT -  +20.0 
+21.0 Lbyte 

Bit 
Bit 
Bit 
Bit 
Bit 
Bit 
Bit 
Bit 

- 
8 
9 
10 
11 
12 
13 
14 
15 

 
 
 
Set Trend Alarm On/Off switch bit 
 
Set Tolerance value type   (1 = Tolerance in Ton,  0 =  
Tolerance in Percent) 
 
 

CHAPTER 3 
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Alarm Reset Bit 
Set this bit On(1) for at least 50ms or longer to clear all present alarm condition of the module.  

 
Set Calibrate Mode Bit 
When set On (1), the module is in calibration mode.  No alarms are active.   
Note: all other mode bits must be off. 

 
Set Peak Mode Bit  
When set On (1), the module is in setup mode.  Capacity alarms are active. 
Note: all other mode bits must be off. 

 
Set Monitor Parts Mode Bit 
When set On (1), the module is in monitor parts (trend monitoring) mode. Capacity alarms and 
trend alarms are active. 
Note: all other mode bits must be off. 
 
Set Scale Value 
This is the maximum load rating of the machine per channel. For example, if the machine is 
rated at 500 ton max and two load sensors are installed for the module, then the scale set should 
be 250. 

 
Set Ch1(2) High Capacity Alarm Value 
Integer value of high capacity alarm setting. Range = 0 to 9999.   A value of 0 disables alarm. 
The value entered will not be valid in the module until in Calibrate mode. 

 
Set Sample Count 
Enter one of the numbers (2, 4, 8,or 16). This is the number of cycles for the module to take to 
learn new sample(Target) tonnage for Trend alarm feature. 

 
Set Low Alarm Inhibit Count 
Enter a number of cycles for module to inhibit low trend alarm when sampling is done in 
Monitor mode. To disable this feature, enter ’0’. 

 
Set Ch1(2) High/Low Tolerance Value 
Integer values of high and low limit for trend alarm settings. Values are set in percent or in ton 
and represent the maximum and minimum percent/ton of change off the sample value.  Range  = 
0 to 99% or 0 to 255ton.  A value of 0 disables alarm. 

 
Set Trend Alarm On/Off switch bit 
When set on (1), Trend alarm is active in Monitor part. Set off to disable it. 

 
Set Tolerance value type bit 
When set on(1),  the module takes the High/Low Tolerance value setting as ton. When set off(0),  
the module takes the High/Low Tolerance value setting as percent. 
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SSI-2 PLM   INPUT BLOCK (DB1) 
This data block is an image of the Input of the module. You can monitor the status of the 
module’s operation from this area such as current tonnage readings, tonnage alarm 
conditions, reverse load readings, etc.  

Block:
BD 
DB1 

Data 
Type Bit Description 

+0.0 INT - Communication Counter 
+2.0 INT - Scale Set 
+4.0 INT - Ch1 Peak value in Ton (in PEAK or MONITOR Mode) 

Ch1 Calibrate number (in CALIBRATE Mode)   
+6.0 INT - Ch2 Peak value in Ton (in PEAK or MONITOR Mode) 

Ch2 Calibrate number (in CALIBRATE Mode)   
+8.0 INT - Ch1 Trend deviation in Percent or Ton 
+10.0 INT - Ch2 Trend deviation in Percent or Ton 
+12.0 INT - Ch1 Sample value in Ton  
+14.0 INT - Ch2 Sample value in Ton 
+16.0 INT - Ch1 Reverse Load in Ton 
+18.0 INT - Ch2 Reverse Load in Ton 
+20.0 Bit -  
+21.0 Bit 0 

1 
2 
3 
4 
5 
- 

Ch1 High Trend Alarm Indication Bit  
Ch1 Low Trend Alarm Indication Bit 
Ch2 High Trend Alarm Indication Bit 
Ch2 Low Trend Alarm Indication Bit 
Ch1 Capacity Alarm Indication Bit 
Ch2 Capacity Alarm Indication Bit 
 

+22.0 Bit -  
+23.0 Bit 0 

1 
2 
3 
4 
5 
6 

Module In Calibrate Mode Indication Bit 
Module In Peak Mode Indication Bit 
Module In Monitor Mode Indication Bit 
Sampling in progress Indication Bit 
Sample Ready Indication Bit (stay On until the mode changes) 
Alarm Rest in progress bit 
CAM Trigger toggle bit 

+24.0 INT - Cycle Counter 

CHAPTER 3 
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Communication Counter 
This counter increments when the data block has been refreshed (updated). 
 
Scale Set 
Reports current scale setting of the module . 
 
Ch1(2) Peak value in Ton /  Calibrate number 
This integer word represents the peak load on channel 1(2) in Peak and Monitor Mode. 
In Calibrate mode, this displays the sensor’s balance reading or calibration(gain) readings. 

 
Ch1(2)Trend Deviation in Percent or Ton 
This integer word represents the difference between current peak load and sample peak load, in 
percentage or tonnage. This value can be used to control Trend deviation LED type display 
(Only valid in Monitor mode). 
 
Ch1(2) Sample value in Ton 
This integer word represents the average of the load values in Tons when learning(sampling) 
cycle is completed in Monitor mode.  

 
Ch2 Reverse Load in Ton 
Integer word represents the peak reverse load value in tons for the current machine cycle. 
 
Capacity Alarm Indication Bit 
When on (1), the current peak tonnage of the channel has met or exceeded the Capacity alarm set 
limit. 

 
High Trend Indication Alarm Bit 
When on (1), the current peak tonnage has met or exceeded the high tolerance percentage or 
tonnage setting  from the sample tonnage. 

 
High Trend Indication Alarm Bit 
When on (1), the current peak tonnage has met or become below the low tolerance percentage or 
tonnage setting  from the sample tonnage. 

 
Module In Calibrate Mode Indication Bit  
This bit is reported by the module that it is actually in Calibration mode when On(1). 

 
Module In Peak Mode Indication Bit  
This bit is reported by the module that it is actually in Peak mode when On(1). 

 
Module In Monitor Mode Indication Bit  
This bit is reported by the module that it is actually in Monitor mode when On(1). 
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CHAPTER 3  

 
 

Sampling in progress Indication Bit  
This bit is reported by the module that it is currently in learning(sampling) mode when On(1). 
 
Sample Ready Indication Bit (stay On until the mode changes) 
This bit is reported by the module that it completed the learning cycle and established new 
sample tonnage when On(1). 

 
Alarm Reset in Progress Bit 
This bit is reported by the module that it is currently resetting all alarm conditions when On(1). 

 
CAM Trigger Toggle Bit 
This bit toggles between 0 and 1 when there is a state change of the CAM input from low to high. 
If there is no CAM input state change, the bit remains the same as the last bit’s state.  
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Chapter 4 
 

Initial Hardware Setup Procedures 
 

 A complete listing of a sample Siemen’s ladder logic program is included at the back of 
this manual. Examples shown here are for reference. 

 
 

All values are 0 (default) on initial start-up.  This means that all alarms are 
disabled.  You must make the following adjustments for proper operation: 

      
• set station number 
• set hi/low 
• set scale value 
• set auto zero (az) control 
• set channel 1 calibration 
• set channel 2 calibration 

 

Menu Sequence: 

efault on power-up) 

 

7. module mode 
 

tep 1.  Set the Station Number 

⇒ 

 number by pressing the up/down buttons to coordinate 
with the Profibus communications. 

 

 
 

 
1. ch1 cal (d
2. ch2 cal 
3. station 
4. hi / lo 
5. scale
6. az 

S
 

From the HM-2-SSI module, press SELECT until “station” scrolls across the display. From 
this menu you can change the station
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Step 2. Set the Hi/Low Gain Range 
⇒ Press SELECT until “hi/low” scrolls across the display.  Change the module’s hi/low alarm 

settings from here. 
⇒ LOW = 140k CAL resistor range. 
⇒ HI = 1M CAL resistor range. 
 

Step 3. Set the Scale Value 
⇒ Press SELECT until “scale” scrolls across the display.  Use the up/down buttons to set the 

scale value to coordinate with the tonnage of the press the module is communicating with. 
 

Step 4. Auto-Zero (AZ) Control 
⇒ Press SELECT until “az” scrolls across the display.  The auto-zero value is normally set to 

‘on’.  Set to ‘off’ only on special circumstances. 
 

Step 5. Click on Calibration Mode 
⇒ Using the software operator interface, click on Calibration Mode to put the HM-2-SSI 

module into Cal Mode so calibration can be completed. 
 

Step 6. Confirm that Profibus Communications are Online (Solid Green Status LED) 
⇒ Using the software operator interface, click on Calibration Mode to put the HM-2-SSI 

module into Cal Mode so calibration can be completed. 
 

Step 7. Calibrate Channel 1 
⇒ Press SELECT until “ch1 cal” scrolls across the display.  Under this menu, users can change 

three values: balance value, calibration value, and az value. 
 

⇒ Balance Mode → using the balance potentiometer, you can manually adjust the balance 
to zero. 

 
⇒ Calibration Mode → using the gain potentiometer, a user can manually adjust the setting 

to their desired calibration number. 
 

⇒ Auto-Zero Mode → when AZ is turned on, this Mode will automatically zero this value. 
 

Step 8. Calibrate Channel 2 
 
⇒ Repeat Step 6 using ‘ch2 cal’. 
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Install GSD File Procedures 
 

Step 1. Begin by opening up SIMATIC Manager. 
 

Step 2. In SIMATIC Manager, click File → New. 
 

Step 3. Type gsdinstall for the project name, and click OK. 
 

Step 4. From the menu toolbar, click Insert → Station → SIMATIC 300 Station. 
 

Step 5. Double click SIMATIC 300  → Hardware. 
 

Step 6. From the menu toolbar, click Options → Install GSD File. 
 

Step 7. Browse to locate the .gsd file, and click install, then OK, and then Close. 
• Can be located on the installation CD provided by Helm 

 
Step 8. Keep SIMATIC Manager open, but close the current gsdinstall project. 
 
 

 
 

Install Siemen’s Ladder Logic Procedures 
 

Step 1. In SIMATIC Manager, click File → Retrieve → Select File → Open. 
 

Step 2. Accept the default directory, and click OK. 
 

Step 3. Click OK, then click OK to the next dialog that appears as well. 
 

Step 4. Double click SIMATIC 300 Station → Hardware. 
 
Step 5. From here, you are able to view/edit the hardware configurations of the card, by 

double clicking the card’s bitmap. 
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Add a New Module 
 
Step 1. In SIMATIC Manager, click File → Open → [saved application] 
 
Step 2. Double click the Simatic X00 Station 

• X is the version number of the station that you are using 
 

Step 3. From this screen, click on PROFIBUS DP master system 
• The bottom part of your screen should say PROFIBUS DP master system 
• If you do not click on this first, you will not be able to continue to add a new 

module. 
 

Step 4. Now from the toolbar, click Insert → Insert Object 
 
Step 5. From the pop-up, click Additional Field Devices → General → SGI 2 Channel 

• If done properly, the properties window will appear. 
 
Step 6. Document the Address that is displayed in the textbox. 

•  Notice that the address provided is incremented from the address of the 
previous module.  This is done to avoid two modules obtaining the same 
address. 

• This address number is actually the station number of the module. 
 

Step 7. Click OK 
 

Step 8. Click the new module, and document the I Address (PIW Address), as well as the 
Q Address (PQW Address) that can be found in the bottom display box. 

 
Step 9. Create a database for the new module by opening and existing database and 

saving it as “DB(Address)”. 
• Example: Address = 4, so the database name is DB4 

 
Step 10. Now open OB1 from your application 
 
Step 11. In FC25 change: 

• PIW address to the PIW address that was documented from step 8 
• DB_ Num to the address that you documented from step 6 

 
Step 12. In FC26 change: 

• PQW address to the PQW address that was documented from step 8 
• DB_ Num to the address that you documented from step 6 
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Chapter 5 
 
 

System Troubleshooting Guide 
 

 
 

HT-400 Sensor Ohm Readings 
 

Green-Black…………………………  350 ohms 
Red-White…………………………...  350 ohms 
All other color combinations…..……  266 ohms 
All colors to Ground...………………  open 
Shield to Ground.……………………  open 
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Parallel
parallel

Correct problem

Out of

Check press parallelism

Capacity alarm fired

Tolerance alarm fired

No alarm

None

No

Yes

Yes

Correct problem

run press
Remove slug and

press or die damage
collar, linkage, or other
Check for broken shear

in die
Check for slug build-up

Alarm does reset
with press stopped

press running
Re sample with

Set mode to Peak

Alarm does not reset
with press stopped

Monitor Parts Mode
Alarm in
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None

None Parallel

ParallelOK

Parallel

in die
Check for slug build-up

Yes
Remove slug
& run press

in die
Check for slug build-up

Yes
Remove slug
& run press of press

Check the parallelism

parallel

Out of
problem
Correct

of press
Check the parallelism

parallel

Out of
problem
Correct

deformed shear collar
Check for broken or

Broken

wear collar
Replace

deformed shear collar
Check for broken or

Broken

wear collar
Replace

Tonnage readings HIGH
on adjacent corners

Tonnage readings HIGH
on one corner

parallel

Out of

Yes

Broken
Replace

wear collar

Correct
problem

& run press
Remove slug Check for slug build-up

in die

of press
Check the parallelism

deformed shear collar
Check for broken or

on diagonal corners
Tonnage readings HIGH

distribution
Uneven load
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Appendix A: Specifications:
 

Electrical Specifications: 
 

Power Consumption 146 MA at 24 vdc 

Number of Channels 2 (isolated) 

A/D Conversion Method 12 bit 
Normal Mode Rejection 
     (between + input and - 
input) 

50 db at 2000 gain 

AMP roll-off frequency 650 Hz at 3000 Gain  

Calibration Software Selectable 

Physical Specifications: 
 

Press Buttons 4 buttons for menu navigation and selection 

LED Indicators 3 LEDs for Calibration, Auto-Zero, and Status 

Recommended Cable Strain Gage Cable (Helm part number 6117) 

Terminal Strip 8-pin removable 

Environmental Specifications: 
 

Operating Temperature 0°C to 60°C (32°F to 140°F) 
Hazardous Environment 
Classification Class 1 Division 2 Hazardous Environment 

Input Specifications: 
 

Type of Input Strain Gage (350 ohm, 700 ohm) 

Input Impedance 1K 

Display Resolution Up to 0.1% of full scale 

Overall Module Accuracy 1% of full scale 

Module Update Time 100 µsec 
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 Appendix B: Module Diagrams:

HM2-SSI Load Module 
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Profibus Field Wiring Diagram 
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“Peak-Only” Strain Gage & I/O Connector Wiring 
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I/O Wiring Connection 
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Appendix C: GSD File:
 
;---------------------------------------------------------------------------------------------------------; 
; GSD PROFIBUS DP                         ; 
; Fa. HELM INSTRUMENT COMPANY 361 West Dussel Dr. Maumee, OH 43537 ; 
; Tel.: 419.893-4356 ; 
; Stand: 05.12.06 ; 
;---------------------------------------------------------------------------------------------------------; 
#Profibus_DP 
GSD_Revision=2 
Vendor_Name  = "HELM INSTRUMENT"   
Model_Name  = "SGI 2 CHANNEL" 
Revision  = "1.0" 
Ident_Number  = 0x1234 
Protocol_Ident  = 0     ; PROFIBUS_DP Protocol 
Station_Type  = 0     ; Slave-Station 
Hardware_Release = "02" 
Software_Release = "V3.00" 
9.6_supp  = 1     ; Baud rate 9.6kB 
19.2_supp  = 1     ; Baud rate 19.2kB 
93.75_supp  = 1     ; Baud rate 93.75kB 
187.5_supp  = 1     ; Baud rate 187.5kB 
500_supp  = 1     ; Baud rate 500kB 
1.5M_supp  = 1     ; Baud rate 1.5MB 
3M_supp  = 0     ; Baud rate 3MB 
6M_supp  = 0     ; Baud rate 6MB 
12M_supp  = 0     ; Baud rate 12MB 
MaxTsdr_9.6  = 60 
MaxTsdr_19.2  = 60 
MaxTsdr_93.75 = 60 
MaxTsdr_187.5 = 60 
MaxTsdr_500  = 100 
MaxTsdr_1.5M = 150 
MaxTsdr_3M  = 250 
MaxTsdr_6M  = 450 
MaxTsdr_12M = 800 
Bitmap_Device = "Helmn" 
Implementation_Type = "SPC3"    ; ASIC SPC3 
;OrderNumber ="A2000 L2" 
Freeze_Mode_supp = 0     ; Freeze Mode 
Sync_Mode_supp = 0     ; Sync Mode 
Auto_Baud_supp = 1     ; Auto-Baud Rate 
Set_Slave_Add_supp = 0 
Min_Slave_Intervall = 1 
Modular_Station = 0 
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 0=Kompaktgerät, 1=Modular 
Max_Diag_Data_Len = 6; 
; 
; 
Module= "16Words In, 16Words Out" 0x5f,0x6f 
EndModule 
;Slave_Family=3 
Slave_Family=0 
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Appendix D: Address Values:
 

Input Image: 

Block:
BD 
DB1 

Data 
Type Bit Description 

+0.0 INT - Update Counter 
+2.0 INT - Communication Counter 
+4.0 INT - Ch1 Peak value in Ton (in PEAK or MONITOR Mode) 

Ch1 Calibrate number (in CALIBRATE Mode)   
+6.0 INT - Ch2 Peak value in Ton (in PEAK or MONITOR Mode) 

Ch2 Calibrate number (in CALIBRATE Mode)   
+8.0 INT - Ch1 Trend deviation in Percent or Ton 
+10.0 INT - Ch2 Trend deviation in Percent or Ton 
+12.0 INT - Ch1 Sample value in Ton  
+14.0 INT - Ch2 Sample value in Ton 
+16.0 INT - Ch1 Reverse Load in Ton 
+18.0 INT - Ch2 Reverse Load in Ton 
+20.0 Bits -  
+21.0 Bits 0 

1 
2 
3 
4 
5 
- 

Ch1 High Trend Alarm Indication Bit  
Ch1 Low Trend Alarm Indication Bit 
Ch2 High Trend Alarm Indication Bit 
Ch2 Low Trend Alarm Indication Bit 
Ch1 Capacity Alarm Indication Bit 
Ch2 Capacity Alarm Indication Bit 
 

+22.0 Bits -  
+23.0 Bits 0 

1 
2 
3 
4 
5 
6 

Module In Calibrate Mode Indication Bit 
Module In Peak Mode Indication Bit 
Module In Monitor Mode Indication Bit 
Sampling in progress Indication Bit 
Sample Ready Indication Bit (stay On until the mode 
changes) 
Alarm Rest in progress bit 
CAM Trigger toggle bit 

+24.0 INT - Cycle Counter 

Appendix D 
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Output Image: 

Block:
DBDB2 

Data 
Type Bit Description 

Bit 
Bit 
Bit 

0 
1 
2 

Set Calibrate mode 
Set Setup mode 
Set Monitor Mode 

+0.0 
+0.1 
+0.0 
+1.0 
+1.1 
+1.2 

Bit 
Bit 
Bit 

8 
9 
10 

 
Alarm Reset  
 

+2.0 INT - Spare 
+4.0 INT - Set Ch1 High Capacity Alarm Value (in Calibrate mode) 
+6.0 INT - Set Ch2 High Capacity Alarm Value (in Calibrate mode) 
+8.0 INT - Set Sample Count (2, 4, 8, or 16) 
+10.0 INT - Set Low Alarm Inhibit Count 
+12.0 INT - Set Ch1 Low Tolerance value 
+14.0 INT  Set Ch1 High Tolerance value 
+16.0 INT  Set Ch2 Low Tolerance value 
+18.0 INT - Set Ch2 High Tolerance value 

INT -  +20.0 
+21.0 Lbyte 

Bit 
Bit 
Bit 
Bit 
Bit 
Bit 
Bit 
Bit 

- 
8 
9 
10 
11 
12 
13 
14 
15 

 
 
 
Set Trend Alarm On/Off switch bit 
 
Set Tolerance value type   (1 = Tolerance in Ton,  0 =  
Tolerance in Percent) 
 
 

Appendix D 
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Appendix E: Siemen’s Ladder Logic:
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