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Preface 
 

Read this preface to familiarize yourself with the rest of this manual.  This preface 

covers the following topics: 

 who should use this manual 

 the purpose of this manual 

 terms and abbreviations 

 conventions used in this manual 
 
 
 

Who Should Use this Manual 

 
Use this manual if you own a palm pilot with Compass Palm™ software installed and you 

would like to analyze the data required from your palm. 

You should have a basic understanding of how to install software on a personal 

computer.  You should understand how to use the HotSync Manager software that was 

provided with Palm Desktop that is provided with your palm pilot, or you can download 

from Palm’s website. 

 

 

Purpose of this Manual 
 

This manual is an installation, learning, and reference guide for the Compass PLM4 

DeskView™ software.  It contains the information you need to install, use, and 

troubleshoot the software.  

http://www.palm.com/us/software/desktop/
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Contents of this Manual 
 

CHAPTER TITLE CONTENT 

 
 

Preface 

 

Describes the purpose, background, and 

scope of this manual.  Also specifies the 

audience for whom this manual is 

intended and defines key terms and 

abbreviations used throughout this book. 

 

Chapter 1 

 

Overview 

 

Gives a description of the advantages that 

the Compass PLM4 DeskView can give its 

users.  Also, gives the audience an overall 

picture of the kind of communication that 

happens. 

 

Chapter 2 

 

Getting Started 

 

Helps getting DeskView running smoothly.  

Quickly.  By giving step by step 

instructions to install Compass DeskView. 

 

Chapter 3 

 

User Guide 

 

Provides a more in-depth description of all 

the different features that the software 

makes available to its users. 

 

Chapter 4 

 

Screen Descriptions 

 

Illustrates a few of the different screens 

that users will come in contact with. 

 

Appendix A 

 

Troubleshooting 

 

Troubleshooting Questions 
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Common Techniques Used in this Manual 
 

The following conventions are used throughout this manual: 

 Bulleted lists such as this one provide information, not procedural steps. 

 Numbered lists provide sequential steps or hierarchical information. 
 

 

Product Support 
 

Contact your Helm representative or call Helm direct at (419) 893-4356: 

 Sales and order support 

 Product technical training 

 Warranty support 

 Support service agreements 
 
 
 

Your Questions or Comments on this Manual 
 

If you have any suggestions for how this manual could be made more useful to you, 

please send us your ideas. 



 

1 | P a g e  
 

Chapter 1 - Overview 
  

You have just purchased the Compass PLM4 DeskView software that works in 

conjunction with the Compass PLM4 to further analyze and monitor the data 

taken from your PLMs using your palm pilot. 

At HELM INSTRUMENT COMPANY, INC., quality is inherent not only in the design of 

our products but in the attitudes of our employees as well.  We’re working 

together to give you the best.  After all, that’s what our business is all about - 

providing innovative programming to help make your manufacturing process 

more productive and your operation more effective. 

DeskView receives data that is taken from Compass PLM4 Palm Software during 

every HotSync.  Using this data, DeskView can further help you analyze 

waveforms, edit notes, and print the data in a user-friendly desktop application. 

 

 

 

 

 

 

 

PLM4 

 

PLM4 PLM4 

Compass 

PLM4 Palm 

HotSync 

Compass PLM4 

DeskView 
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Required Software 
 

Compass PLM4 Palm Software 

This software is used on palm pilots that use the Palm OS, and is used 

with Compass PLM4 DeskView.  These two programs work much like a 

palm pilot’s operating system, and the Palm Desktop software.  Palm 

Desktop is used as a desktop extension of the palm pilot’s handheld 

software. 

Palm Desktop 

This software is provided by Palm.  It is needed to be installed before 

DeskView is installed, because DeskView uses the HotSync action that is 

provided with Palm Desktop. 

 

 

Compass PLM4 DeskView Features 

 

 View all a user’s records from one screen 

 Store records on your computer to save space on your palm pilot 

 Export records as a ‘.csv’ file that is compatible with spreadsheet 

applications 

 Support for several palm pilots 

 Zoom a waveform on your desktop 

 View multiple waveforms overlaying each other 

 Better analysis of a waveform by hiding channels that you would like to 

ignore 

 Edit notes on the waveform viewing screen 

 Save waveform as EMF file for easy viewing 

 Print waveforms

http://www.palm.com/us/software/desktop/
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Chapter 2 - Getting Started 
 

This chapter can help you to install DeskView on your computer.  The 

procedures included here assume that you have a basic understanding how to 

install software on a Windows operating system. 

Because this is a start-up guide, this chapter does not contain detailed 

explanations about the procedures listed.  It does, however, reference other 

chapters in this book where you can get more information about applying the 

procedures described in each step. 

If you have any questions or are unfamiliar with the terms used or concepts 

presented in the procedural steps, always read the referenced chapters and 

other recommended documentation before trying to apply the information. 

This chapter will: 

o Tell you what equipment you will need 

o Explain how to install the software 

 

Required Equipment 

 
You must have the following hardware to use DeskView: 

o PLM4 

o Palm pilot with Compass PLM4 Palm Software installed 
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Installation Procedure 
 

1. Install Palm Desktop 

a. Skip this step if you already have Palm Desktop installed. 

2. Install Compass PLM4 DeskView 

3. Install Compass PLM4 DeskView HotSync Conduit 

a. Open DeskView 

b. Click Tools → Compass PLM4 Conduit Installer 

 

 

c. Click Install Conduit 

 

 

d. Click Close 
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4. Perform first HotSync 

a. Connect Palm HotSync USB cable to the palm and the desired 

computer that has DeskView installed. 

b. Perform the HotSync  

 

 

*If any problems occur during installation or HotSync, please see our 

troubleshooting section.
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Chapter 3 - User Guide 
 

This section of the manual will help you get started using Compass PLM4 

DeskView on your computer.  Along with the following instructions included 

here, we assume that you have a basic understanding and previous experience 

using Window applications. 

This chapter is divided according to the features that are provided by this 

software in order to be used as a quick reference.  For example, if you would 

like to print a waveform, you could quickly view the table of contents, and then 

jump to that section in the manual to follow the instructions that are associated 

with printing waveform records. 

If you have any question or are unfamiliar with the terms used or concepts 

presented in the procedural steps, always read the referenced chapters and 

other recommended documentation before trying to apply the information. 

This chapter will show you how to: 

 Retrieve records from your palm 

 Store records on your computer to save space on your palm pilot 

 Transport individual waveforms etc. email, USB 

 Export records as a ‘.csv’ file that is compatible with spreadsheet 

applications 

 Support for several palm pilots using DeskView 

 Zoom a waveform on your desktop 

 View multiple waveforms overlaying each other 

 Better analysis of a waveform by hiding channels that you would like to 

ignore 

 Edit notes on the waveform viewing screen 

 Print waveforms 
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Retrieve Records from Palm 
 

 HotSync the palm with computer 

 

To retrieve records from the Compass PLM4 Palm Software you must HotSync 

the palm to the computer that has the DeskView installed.  Performing a 

HotSync action is the only way to recover records that are on the palm to your 

computer.  If you HotSync your palm to your computer and no records appear 

on the DeskView viewing menu go to ‘Can’t see the records after I did a 

HotSync,’ in the troubleshooting section of this manual to assist you further. 

 

Store Records on Computer 
 

 Records are automatically stored on computer when HotSync occurs. 

 Records are stored in a folder called, ‘WaveData,’ that can be found in 

the Compass PLM4 DeskView root folder. 

 

Transport Waveform Files 
 

 Because all the waveforms are converted into their own .wav file, you 

can email individual waveforms, or put them on a USB drive, etc. 

 This is helpful when you are getting irregular waveforms and you would 

like to have them analyzed by an associate. 

 NOTE:  The above method requires Compass PLM4 DeskView to be 

installed on the machine in order to view the wav file. 

 Take a snapshot of the waveform, and save it into a EMF, Enhanced 

Media file.  All EMFs are saved to the “Saved Wave Bitmaps” folder 

located in the Compass PLM4 DeskView root folder. 
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Export Records to Excel Format 
 

1. Click on the record/s that you would like to export, and then click, 

“Export.”  You will be greeted with a window allowing you to save the 

exported file/s wherever you would like.  However, this is defaulted to a 

folder named, “Exported CSV.”  This folder can be found at DeskView’s 

root folder. 

2. You can also click on, “Export all,” which will convert and export all that 

wave files that are in the viewing window. 

 

 These files are exported as CSV files, and therefore can be opened and 

viewed by spreadsheet applications. 

 

Support for Multiple Palms 

 
All palms have a configurable user name.  The software keeps track of every 

new and old user that performs a HotSync.  It uses the same user information as 

the Palm Desktop uses.  So for example, if you would like to remove a user, you 

can do it simply by doing it in the Palm Desktop.  To select a different user’s 

records, follow these steps: 

 Press File → Select User 

 Choose the user you would like to view 

 Click View, and the viewing window will update automatically to display 

the selected user’s records.
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Zoom In/Out 
 

 Click and drag the mouse over the area that you would like to zoom 

from top left, to bottom right. 

 Zoom back out by dragging from bottom right, to top left 

 

Overlaying Waveforms 
 

 From the record viewing window, select multiple records (5 max), and 

then click ‘Show’ 

 Wave Form window will open, displaying the selected records 

 

Hide Channels on Wave Form Window 
 

 When you are viewing a waveform in the Wave Form window,  in the 

toolbar,  there is  ‘Selection X’ 

 In the Selection X menu, all channels are on by default, but you can turn 

them off to hide them from the graph by simply clicking the Channel 

that you would like to hide 

 If the channel has a checkmark to the left of it, it is on 
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Edit Notes on Waveforms 
 

All notes that you put on waveforms from you palm, are downloaded to 

DeskView when you HotSync them together.  DeskView allows you to edit these 

notes, or add your own.  You are only permitted to edit notes or add your own 

notes to waveforms that have been downloaded to DeskView’s wave history.  

To edit or add a note, first open DeskView: 

 Click Tool → View WAV History 

 Under ‘WaveData’, browse to the sequence number that the wave 

record would be under. 

 Double click the wave file that you would like to open and view 

 Then click at the top left hand corner where you will either see ‘Note:*’, 

or ‘No Attached Note’ 

 Edit the note to your desire 

 Click Close 

 

Printing Waveforms 
 

You now have the option to print the wave form that you originally captured 

from you palm pilot.  You can print waveforms from the ‘Wave Form’ window: 

 Open DeskView 

 Double click on a record 

 From the ‘Wave Form’ menu, click File → Print 

 The currently viewed record will then be printed 
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Chapter 4 - Screen Descriptions 
 

 

Record Viewing Window 
 

 

 

The ‘Record Viewing Window’ is essentially the main menu of the DeskView.  

From this screen, you can navigate to any of the features that this program 

provides.  Each selection is referred to as a record. 

Double clicking on a record in the ‘Wave Data’ area, will open the ‘Wave Form’ 

window that will graph the selection.  To better understand the ‘Wave Form’ 

window, please refer to ‘Wave Form Screen’ section of the manual. 

From this screen, you can also export your selections into a spreadsheet 

compatible format (.cave) to be viewed and analyzed. 
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Wave Form Window 
 

 

 

This screen allows you to view the waveform of the record, as well as the peak 

tonnages.  From this screen you can zoom, and print the waveform. 

 

Select User Window 
 

 This small window is used 

to select a user whose 

records that you would 

like to view.
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Appendix A:  Troubleshooting 
 

Q.  When I install Compass DeskView, it errors, and tells me I am 

missing a dll or ActiveX Object? 
 

A.  This has been known to happen when DeskView is installed prior to Palm 

Desktop.  To resolve the issue, please download the most current version of 

Palm Desktop from their website, and then install Compass PLM4 DeskView. 

 

Q.  I HotSync my palm with my computer, but DeskView doesn’t 

show me the records that I have on my palm? 
 

A.  Most likely the conduit for the DeskView was not installed properly, or 

there was a problem during installation.  To resolve this issue, please follow 

the instructions below: 

1. Click Tools → Compass PLM4 Conduit installer 

2. Remove Conduit 

3. Install Conduit 

4. HotSync, and wait for this to complete 

5. Click Tools → Update 

 
A.  This can also happen when you HotSync a palm with one user name, and 

DeskView is displaying the records of another user name.  Please check the 

user name that is on the palm that you preformed the HotSync with, and 

continue to follow the steps below: 

1. Click File → Select User 

2. Select the user name that is on the palm 

3. Press View  

 


